มี 2 VLAN แล้วอยากให้เรียกหากันได้ด้วย Computer Name ทำอย่างไร (แจก Script) โดยคุณ {tondev} พ่อมดไอที

วิธีการคือใส่ Script ลงใน DHCP Server เพื่อให้สร้างชื่อใน DNS ของระบบ จากนั้นเครื่องที่อยู่ภายใต้ Router เดียวกัน ไม่ว่าจะกี่ VLAN ก็จะสามารถเรียกหากันได้ โดยตัวสคริปต์สามารถก๊อปปี้ได้ตามที่อยู่ใต้ Video ได้เลยครับ โดยคุณ {tondev} พ่อมดไอที จากกลุ่ม Mikrotik ใน Line OpenCHAT https://bit.ly/MikrotikLineOpenCHAT

:local lease [/ip dhcp-server lease print active as-value where mac-address=$leaseActMAC];
:local hostname $"lease-hostname";
:local expires ($lease->0->"expires-after");
:local tld ".mt";
:local dnsStatic [/ip dns static print as-value where name="$hostname$tld"];

:if ($dnsStatic = "") do={
 log info "Add static DNS $leaseActIP > $hostname$tld"
 /ip dns static add name="$hostname$tld" address=$leaseActIP type="A" ttl=$expires
} else={
 :local lease2 [/ip dhcp-server lease print active as-value where host-name=$hostname];
 if ($lease2 != "") do={
  log info "Update static DNS $leaseActIP > $hostname$tld"
  /ip dns static set [find name="$hostname$tld"] address=$leaseActIP ttl=$expires
 } else={
  log info "Delete static DNS $leaseActIP > $hostname$tld"
  /ip dns static remove [find name="$hostname$tld"]
 }
}
Exit mobile version